Why isn't Shopify loading properly on Google Chrome?

Why isn't Shopify loading properly on Google Chrome?

Mubashir8
Visitor
3 0 0

I'm trying to access shopify.com but its not loading properly on google chrome. However other sites are working properly. I checked shopify on other browsers and it worked perfectly. I don't know what the problem is. I uninstalled and reinstalled the browser and it is up to date. All settings are default. I rebooted my system too still shopify is not loading. Hope someone would help me.
Thank You

shopify error.PNG

 

Replies 14 (14)

DigitalArtisans
Shopify Partner
378 58 89

Hello @Mubashir8 !


1. Make sure your are not using Google chrome in incognito mode
2. Chrome browser extensions or cache/cookies are causing the issue clear your cookie and cache
3. If you have a VPN/Firewall/Adblocker installed, disabling the option may help resolve the error.

Hope this helps!


Thanks,
Digital Artisans

Hatim Ayoub | Designer | Developer
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted
Mubashir8
Visitor
3 0 0

Thanks for replying.


1. I'm not using incognito mode, however even if I try there the problem is same.

2. No extension is added. No cookies accepted from any website. All settings are default.

3. I'm not using any VPN/Firewall/Adblocker.

DigitalArtisans
Shopify Partner
378 58 89

Hello @Mubashir8 , 


You need to remove existing cache and cookies.
Try the older version of google chrome.


Thanks,
Digital Artisans

Hatim Ayoub | Designer | Developer
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted
Mubashir8
Visitor
3 0 0

Thanks for replying.

1. I did clear cache and cookies.
2. Tried the older version of google chrome

but still the problem persists.

GMaximus
Tourist
3 0 2

IDENTICAL problem here.  did you fixed it?

mahavonjy
Visitor
2 0 0

The same problem with Chrome 

 

image.jpg

Dave_Dollar
Visitor
1 0 0

I have just created a Shopify Site and the images do not display in Chrome while on Microsoft Edge Chromium the images load immediately

GMaximus
Tourist
3 0 2

It's an issue with windows update because I had the same problems and I tried all the solutions out there in the web, so update your windows.

 

farooq21
Shopify Partner
1 0 2

If anyone facing the same issue even after clearing the cache and updating chrome then definitely your PC time is incorrect.
I was facing the same issue as others were facing, applying all steps, and then after correcting the time solved my issue.

Sahibshabir
Visitor
1 0 0

I click on free trail it shows me loading then it takes me directly to page where we select country.the main setup can't load where we give email, password,and store name,but when I preceding it from country page it takes me another page where store created but finally it shows store not created try again.

I tried different divces and browsers but it shows same. Plz I need help

Jcook
Visitor
1 0 0

I had this same problem and I'm going to tell you what I did and have seen so it might help others.

First I have to tell I'm working on a 2007 iMac with big sur i added on to it. It's not supported. All my sites looked like this so I had to install new root certificates SSL. 

I downloaded it from let's encrypt as this is a trusted source.

Then everything worked correctly.....

Until I could not get on Shopify anymore after a month of normal working.

Butttt I also could not get it on my newer 2020 Chromebook, so something was wrong. I tried incognito and it for some reason did work, but off course I don't want to use incognito. thought I could not update my 2007 iMac browser and my certificates were correct so it must be because of the outdated browser unfortunately. Well untill it was on my Chromebook.

 

So I tried everything mentioned already in this help center. I tried incognito and it for some reason did work, but off course I don't want to use incognito. It turned out is was all the add blockers I was using and nothing special!! You can use your Add blockers on specific websites but I turned it off completely and it works for me.

 

I hope you can somehow use any information I told ya here 🙂

 

This also included for my 2007 iMac and now everything works correctly.

JMG
Visitor
2 0 0

I'm on a brand spanking new mac air. Latest operating system. Chrome is most recent version and about 2 weeks ago it started showing prices on my shopify site as EURs and just the other day it switched to CHF! And now it is not displaying all the items in each category!!!! Yes works perfectly an all other browsers and incognito. Oh when I went to try a check out since it had my contact info the order was processed in dollars. Is there any explanation?

 

Imogen
Shopify Staff
1890 212 338

Hi there, @JMG. Thanks for taking the time to follow up on this thread! My name is Imogen. It's good to meet you!

 

Thanks for sharing this context with us. It's certainly odd to hear that you're seeing your store shown in different currencies when using Google Chrome and not when using other browsers, as your store's currency is usually based on settings you control within your admin that should be applying across all browsers. This certainly sounds like is an issue tied to your Chrome Browser specifically. If you've tested using different browsers and incognito windows with the same version of Chrome, and you don't have these issues, then I would recommend uninstalling and re-installing chrome to see if this addresses these chrome-specific issues you're experiencing.

 

If your issues persist, then I would suggestion that you reach out to our Shopify Support Team via our Help Center so we can collect some store specific information from you and look into additional troubleshooting options.

Imogen | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

JMG
Visitor
2 0 0
I just finished a chat session where the issue is being sent to the tech department. I noticed that there were several other people posting the same problem. We shall see what they come up with